About NCknows

Using NCknows

Participating Libraries

Technical Requirements

Home

Technical Requirements

For best use of NCknows, we recommend using:

Microsoft Internet Explorer 5.0 or later and
A 28K or faster Internet connection.

For chatting and sharing web pages, you will need these minimum system requirements:
( Note: Full two-way cobrowsing is NOT possible with this configuration)

  • A web browser: Microsoft Internet Explorer 6, Netscape, Firefox, Opera and Safari
  • A connection to the internet (the faster the connection the better the experience)

To co-browse websites with a librarian, you will need:

  • A web browser: Microsoft Internet Explorer 6.
  • Microsoft Windows (2000 or XP)
  • A virtual machine (Java engine) from either Microsoft (version 1.1.4) or Sun Run Time Environment 1.4 or 1.5
  • A connection to the internet (the faster the connection the better the experience)

Note: You may need to disable firewall or pop-blocker protections to be able to chat back and forth. If you are unable to chat, please try us again and leave your email address so we can respond and help you further. Thanks.

NCknows is supported by the Institute of Museum and Library Services under the provisions of the federal Library Services and Technology Act (LSTA), as administered by the State Library of North Carolina, a division of the Department of Cultural Resources.
Do you need help or have a question? Contact us .